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Release Notes

The Community Edition of TIBCO Business Studio is unsupported. For 
self-service support, education, and access to the TIBCO Developer Network, visit 
http://www.tibco.com/devnet/index.html.

Restrictions
The Community Edition of TIBCO Business Studio does not offer/support 
various things offered by other editions, including the following:

• Import of a WSDL from a TIBCO BusinessWorks live link. 

• TIBCO Business Studio Forms, with which you can design, view, and test the 
forms you need to collect user input in a business process from within TIBCO 
Business Studio.

• TIBCO Business Studio Asset Central, which allows you to create a 
Subversion server for source control.

• Deployment to either TIBCO iProcess™ Engine or TIBCO ActiveMatrix® 
BPM.

Contact TIBCO on http://www.tibco.com/company/contactus.jsp for 
information on deployment licensing.

These features are documented in the online help and user guides, but are only 
available with the commercial editions of TIBCO Business Studio.

Topics

• New Features, page 2

• Migration and Compatibility, page 9

• Closed Issues, page 11

• Known Issues, page 22
 TIBCO Business Studio Community Edition Release Notes
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New Features

This section lists features added since the last major release of this product.

TIBCO Business Studio
This section lists new features in TIBCO Business Studio.

Release 3.4

• The Graphical Organization Modeler was enhanced to allow you to create 
typed organization entities directly within the graphical modeler. You are 
provided with a Public Company type, but you can also create your own 
organization entity types to reflect your own organization.

• Ability to create additional diagrams within a single Business Object Model. 
This allows a user to describe subsets of the model to better explain its use. 

• Samples are linked from the TIBCOmmunity site to allow them to be updated 
more frequently.

• Email service tasks now offer better platform independent modeling. 
Associating a system participant allows the user to name the mail server that 
will be used and therefore model if more than one is to be used by the process. 
You will receive an error message if you try to enter an email task without a 
system participant. Server configuration and error handling are now moved 
to the Advanced tab which is consistent with other destination-platform 
specific model (PSM) properties. 

Release 3.2

The following are new features in this release:
TIBCO Business Studio Community Edition Release Notes
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• TIBCO Business Object Modeler Import and Export Enhancements These 
facilities have been significantly enhanced:

— It is now possible to create a business object model by importing tables 
from a database. Each table is automatically mapped to a Class in a 
business object model. 

— It is possible to create a business object model by importing XML Schema 
Definition (XSD) files or WSDL files and automatically converting them to 
a business object model.

— It is possible to export business object models from Business Object 
Modeler as XSD files and as WSDL files.

— It is also possible to export XSD and WSDL for one or more classes, rather 
than a complete business model.

• Additional Resource Pattern Support New resource patterns such as chained 
execution, piling, and retain familiar can now be modeled.

• Process Modeler User Interface Enhancements Several user interface 
enhancements have been added:

— Gadgets A gadget is a user interface aid that allows you to easily create 
sequence flows or other links between objects.

— Palette favorites A new drawer called Favorites has been added to the 
palette in the Process Editor, containing commonly used process objects. 
You can then customize the drawer contents according to your needs.

— Process Editor Quick Fixes Quick fixes that were previously only available 
in the Problems view are now shown on the Process Editor tooltips.

• Correlation Data Correlation data is a new feature that is used to identify 
process instances when working with messages.

• Embedded Sub-Process Local Data Embedded sub-processes now support 
data fields that are local to the sub-process only (the data fields are not 
available to the containing process).

Release 3.1

The following are new features in this release:

Business Process Modeler

• Ganymede Support TIBCO Business Studio uses the Ganymede (3.4) release of 
Eclipse.

• XPDL 2.1 TIBCO Business Studio stores process packages in XPDL 2.1 format.
 TIBCO Business Studio Community Edition Release Notes
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• BPMN 1.2 Major features of BPMN 1.2 are supported such as signal events 
and other notational changes.

• Labels and Names Process objects such as data fields, tasks, and so on, now 
have both a label and a name. Using the Business Analysis capability, only the 
label is visible. Using the Solution Design capability, both the label and the 
name are visible. The name is used to reference process data in scripts and 
sub-processes. When migrating from an earlier version, the migration XSLT 
creates labels from the existing names.

• Greater Control of Destination Environments Destination environments have 
been enhanced to include destination components (for example, there are 
iProcess destination components such as Engine, Modeler, Technology 
Plug-ins, and Web Services). For each component, you can select the version 
that you want processes to be validated against (for example, Engine, version 
11.0.1). You can create your own destination environments that are comprised 
of several destination components for which you can also specify versions. 
The default destination environments, and any destinations you create are 
available on the Destinations tab. Your process is validated against your 
selection on the Destinations tab (and the implicit destination components).

• Importing Custom Fragments Process Fragments can be imported so that 
different users can share custom process fragments.

• Easier Deployment There is a new Deployment view, into which you can drag 
an XPDL file for deployment. If any logical names require mapping, the 
appropriate dialogs are presented.

• Improved Performance Several aspects of TIBCO Business Studio have been 
tuned to be faster, especially with large models. Areas of improvement 
include validation of models, creation of process documentation, and 
transformation to Platform Specific Models (PSM) 

• Showing/Hiding Implementation Details Property pages now have hyperlinks 
that show or hide the right side of the view that contains the implementation 
details for the selected object (for example, the web service details for a service 
task). Clicking one of these links also changes between the Business Analysis 
and Solution Design capabilities as appropriate.

Release 3.0

The following are new features in this release:

Business Process Modeler

• Process Interfaces TIBCO Business Studio supports Process Interfaces, which 
equate to iProcess I/O Parameter Templates. These are used to create dynamic 
sub-procedures and graft steps.
TIBCO Business Studio Community Edition Release Notes
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• Service Tasks Support XML/JMS Transport In addition to SOAP/HTTP service 
calls, TIBCO Business Studio now supports XML/JMS service calls.

• Service Tasks Support URL Aliases, Security Profile Aliases, BusinessWorks 
Endpoint Aliases In TIBCO Business Studio, you can specify a logical name 
(defined as a System Participant) to use at design time rather than specifying a 
specific URL, Security Profile, or BusinessWorks endpoint name. This is 
equivalent to the TIBCO Web Services Plug-in feature of URL and Security 
Profile aliases. At deployment the logical names are mapped to the specific 
information (retrieved using a JMX server).

• Public and Private Activities TIBCO Business Studio now supports the iProcess 
concepts of Public and Private Activities, and allows you to associate Process 
data with those Activities.

• Enhanced Mapper The mapper used for parameter mapping (for example, on a 
Service Task) has been enhanced for better usability. It now also supports both 
XPath and XSLT scripts.

• Auditing Script Support You can now add audit initiated and audit completed 
scripts for Service Tasks and Script Tasks.

• New Inline Sub-Process You can now create an inline Sub-Process from an 
Independent Sub-Process to optimize the Process. At runtime, the objects such 
as Activities and Events contained in the Independent Sub-Process are 
brought into the top-level Process and executed there. 

• Service Tasks Enhancements You can now drag WSDL operations onto 
Service Tasks. You can also import a WSDL directly from the Properties View 
of the Service Task.

• Enhanced Looping Support Standard and Multi-Instance Loops have been 
enhanced to support certain workflow patterns, loop expressions, and scripts.

• Structured Discriminator Pattern Support This pattern means that you can 
specify how many incoming Sequence Flows to a Complex Gateway are 
received before flow continues.

• Workflow Resource Pattern Support The following workflow patterns are now 
supported.

For more information about the Workflow Patterns initiative, see:

http://www.workflowpatterns.com/index.php
 TIBCO Business Studio Community Edition Release Notes
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— Pattern 5: Separation of Duties

— Pattern 14: Distribution by Allocation - Single Resource

— Pattern 15: Random Allocation

— Pattern 16: Round Robin Allocation

— Pattern 22: Resource-Initiated Execution - Allocated Work Item

— Pattern 39: Chained Execution[# 10641]

• Project References Projects can refer to other projects. This allows you to do 
the following:

— Invoke a Sub-Process from another Project

— Use a Process Interface from another Project 

— Create a Data Field or Formal Parameter of the type External Reference 

— Select a WSDL from a different Project

General

• Business Object Modeler In the previous version of TIBCO Business Studio, 
the Business Object Model Editor was called the Concept Model Editor. This 
version of TIBCO Business Studio enables you to create Business Object 
Models, as well as Concept Models. Business Object Models are more generic 
than Concept Models. Concept Models are specialized using a UML Profile 
that extends the meta-data to provide additional functionality over core UML. 
Using the Business Object Modeler, you can now add Primitive Types and 
Operations and apply UML Profiles and Stereotypes to your Business Object 
Models.

• Support for Windows Vista Windows Vista is now a supported platform for 
TIBCO Business Studio.

Release 2.1

The following are new features in this release.

For the Business Analyst:

• Enhanced Process Package Documentation Everything in the model is now 
included in the Process Package Documentation, images are hyperlinked 
(clicking an Activity takes you to Activity detail), and transitions are 
explained. Process Package Documentation can also be generated from the 
command line.

• Welcome Page Improvements The Samples workspace has been replaced by 
ability to install samples into a workspace from the Welcome Page Samples 
TIBCO Business Studio Community Edition Release Notes
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area. The TIBCO Business Studio Community site forum is viewable from 
Welcome page.

• Performance Enhancements The Performance issue with Problem markers 
resolved.

• User-Configurable Problem Thresholds Users can now configure the severity of 
reported Problems.

For the Process Developer:

• Open, Close, and Submit Scripts - Scripts can be specified on a User Task that 
when exported or deployed to iProcess Engine become Initial, Keep and 
Release scripts.

• Improved Usability Both the Mapper and the Service Explorer have been 
enhanced.

• Support for EAI POJO Users can now specify Java code that is executed at 
runtime in a new EAI POJO step in iProcess Engine.

• Linux support Red Hat and SUSE (see TIBCO Business Studio Installation Guide 
for details).

General:

• Installer does not require JRE to be pre-installed.

Release 2.0

The following are new features in this release.

• BPMN Complete Set TIBCO Business Studio now supports the complete set of 
Business Process Modeling Notation (BPMN). For more information, see 
http://www.bpmn.org. 

• Improved Process Editing The Process Editor has been improved with a 
revised Palette and new features such as Diagram Fragments and Sub-Process 
refactoring.

• Enhanced Service Tasks You can now configure Service Tasks to call web 
services (including TIBCO BusinessWorks live link), call Java code, send an 
e-mail or run a stored procedure on a database.

• Direct Deployment to destination environments For example, if you have 
iProcess components, you can now deploy a process from TIBCO Business 
Studio directly to the TIBCO iProcess Engine Version 10.6. Users of iProcess 
Engine version 10.3.5 and later may also deploy complete procedures using 
the Procedure Management features of TIBCO iProcess Modeler.

• Enhanced User Tasks You can add Data Fields and Parameters to Users Tasks 
and as input and output Parameters.
 TIBCO Business Studio Community Edition Release Notes
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• Concept Modeler This new editor allows you to define a vocabulary of core 
business objects for analysis and documentation purposes. 

• Aris Import You can now import information from Functional Allocation 
Diagrams (FADs) as well as Extended Process Chain (EPC) diagrams. EPC 
import now additionally caters for intermediate events.

• Asset Central - This new utility provides source control using a bundled 
product, Subversion (see http://subclipse.tigris.org/).
TIBCO Business Studio Community Edition Release Notes
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Migration and Compatibility

This section explains how to migrate from a previous release to this release.

Migrating from Version 3.x
Some files require migration to new formats. These will be highlighted by 
entries in the Problems view. Right-click and select Quick Fix. When you have 
resolved the problems, you can open the process in the appropriate editor.

Migrating from Version 2.x
1. Copy the package containing the process into a packages special folder.

2. Either start TIBCO Business Studio, or if it is already open, refresh the Project 
Explorer.

3. Note that the package cannot be expanded and clicking on it displays the 
following error:

4. In the Problems view for the package, the following error message is 
displayed:

Right-click and select Quick Fix. When you have resolved the problems, you 
can open the process in the Process Editor.

Migrating from Version 1.1
To migrate from Version 1.1, do the following:
 TIBCO Business Studio Community Edition Release Notes
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1. Depending on whether you are migrating a workspace or a Package, do the 
following:

— To migrate a workspace, select File > Switch Workspace, browse for the 
location of the Version 1.1 workspace, and when prompted, restart TIBCO 
Business Studio.

— If you want to migrate only one Package, and not an entire workspace, 
either copy the Package into the Project Explorer or select File > Import, 
expand General, select Existing Projects into the Workspace, and follow 
the instructions in the wizard to import the Project.

2. Right-click a Project you want to migrate and select Migrate Project to 
Current Version. The icon on the Project in the Project Explorer changes and 
the Project Explorer folder is added.

3. In the Problems view for each Package that you migrated, the following error 
message is displayed:

Right-click and select Quick Fix. When you have resolved the problems, you 
can open the Process in the Process Editor.

Whilst the Project folders are present, the Project Explorer displays the 
contained XPDL files only, without the standard TIBCO Business Studio 
Project Explorer branches such as Process Packages Folders, Data Fields, 
and so on.

You can correct several migration problems at once from the Quick Fix dialog by 
clicking Find Similar Problems, selecting them, and clicking OK to apply the fix. 
The number of similar problems found depends on the filtering that you have set 
up in the Problems view.
TIBCO Business Studio Community Edition Release Notes
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Closed Issues

The section lists issues that were closed in the named releases.

• TIBCO Business Studio

TIBCO Business Studio
This section lists issues that were closed for TIBCO Business Studio in the named 
releases.

Version 3.4.1

None.

Version 3.4.0

None.

Version 3.3.0

Change 
Request ID Summary

XPD-211 Export did not generate the right export file for an Order step of type "This 
Procedure".

XPD-213 Email service task: The %% escape sequence resulted in a validation error.

XPD-219 Simulation: validation error for non-support of performer participant could be 
more descriptive.

XPD-220 Mapping from user scripts to xsd types in a webservice or BusinessWorks service 
task now validates the data types are compatible.

XPD-242 Extended description behavior on export from TIBCO Business Studio has been 
corrected.

XPD-633 Using TIBCO Business Studio on LINUX, you can now connect to a TIBCO 
Administrator Server from with TIBCO Business Studio.

XPD-708 For a Process as a Service with an optional parameter, the generated WSDL has the 
parameter required.
 TIBCO Business Studio Community Edition Release Notes
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Version 3.2.0

Change 
Request ID Summary

1-9DCCYY Firefox version 3.0 was not supported for embedded HTML rendering within 
Eclipse, although Eclipse did support Firefox 3.0 browser windows within the 
Eclipse workbench. 

No problem has been experienced using Firefox 3.0.11 with TIBCO Business Studio 
version 3.2.

1-9DABKX Unable to launch TIBCO Business Studio in a workspace built for an earlier 
version.

1-8ZHBFV If you renamed a file in the Project Explorer but before saving your changes you 
switched to another application, when you went back to the Project Explorer, the 
file had disappeared.

1-8ZHBCS If TIBCO Business Studio reported validation problems in the Problems View for a 
Process Interface or Process and you deleted the Process Interface or Process, the 
validation problems were still displayed in the Problems View. 

1-8ZHB4Z If you renamed a Process Interface event, you did not see the change in the Process 
Editor.
TIBCO Business Studio Community Edition Release Notes
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Version 3.1.0

Change 
Request ID Summary

1-9HN5KJ TIBCO Business Studio sometimes runs out of memory when copying process 
objects that contain large (bigger than 16 MB) images. This has been corrected; 
large images are automatically scaled down to avoid this problem.

1-8ZHB20 Sometimes when you click an element in the Project Explorer, Save is not enabled, 
even if you have made a change to the Package. 

1-8ZHB5E If you are passing process data to a Java service and the POJO meta expects a 
parameter of type Primitive Char and at runtime, you pass an empty value to this 
parameter, then the case will fail.

1-8ZHB8E When selecting TIBCO Business Studio help from the Overview on the Welcome 
page, the Table of Contents links are incorrect for the Help topics. For example, the 
topic displays one guide but the Table of Contents displays the Table of Contents 
for another guide.
 TIBCO Business Studio Community Edition Release Notes
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Version 3.0.1

Change 
Request ID Summary

1-94ZVGV Simulation fails if Formal Parameters used in generated scripts contain invalid 
JavaScript characters.

1-94ZVHL With the Simulation destination environment set for a Process, if you create an 
XOR gateway and specify a Parameter on the Rule Parameter tab, you cannot add 
a Rule on the Rule tab of the outgoing conditional sequence flow.

1-94HUNZ New Parameters are not being created in TIBCO Business Studio for TIBCO 
BusinessWorks WSDL Parameter mappings that have multiple sequences or 
groups.

1-94I5RX The Business Object Modeler documentation export fails to create an image when a 
model element has a restriction applied.

1-94HUQG Expressions used to define Prediction Duration are not correctly validated. This 
has been fixed; a Data Field can now be entered to define Prediction Duration.

1-94HUQT The Delete option is disabled on the right-click menu for some Processes. These 
Processes can be inadvertently deleted by deleting other Processes.

1-94HURT Exporting the Procedure Documentation for a Package can cause the system to run 
out of memory.

1-94HUS6 The post-install notes in the Installation guide refer to the menu item Select 
Window > Validate Business Studio Configuration. This is incorrect, the top-level 
menu item is Help not Windows.

1-94HUST Under rare circumstances a TIBCO Business Studio 2.1 Process cannot be migrated 
to version 3.0, and displays the error message 'Stored Procedure' is not 
legal.

1-94I5PF Sub-Process Tasks that reference a Process Interface or Sub-Process that is 
contained in another Package generate a validation error. This validation error has 
been removed, however the Package that contains the referenced Interface or 
Process should be deployed before the Package that references them. 

1-90DXZQ In a Service Task, XPATH concatenation of String and Boolean field to a WSDL 
Int/Integer parameter deploys without errors, but fails at runtime.

1-90KFZC Repeating elements in the middle of XPath expressions are not validated for 
multiplicity. This applies to both simple and user-defined mappings.
TIBCO Business Studio Community Edition Release Notes
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1-8ZM1O1 The TIBCO Business Studio Installation guide states that TIBCO do not recommend 
installing TIBCO Business Studio Version 3.0 in the same installation environment 
as either; 

• earlier versions of TIBCO Business Studio, or 

• other TIBCO products.

However, you can do this by using a configuration file called platform.xml. The 
platform.xml file should specify:

• that only those features installed by TIBCO Business Studio Version 3.0 are in 
the site located at components\eclipse, and 

• that the policy for that site must be MANAGED-ONLY. 

Please refer to the Eclipse documentation for information on how to create the 
platform.xml file:

http://help.eclipse.org/help32/index.jsp?topic=/org.eclipse.platform.doc.isv/ref
erence/misc/update_platform_xml.html

1-8ZJM2H When writing an XPATH Expression in a user defined script, you must put the 
logical expression within brackets if you want it to be validated correctly. For 
example:

($field1 > 1 or $field2 > 1)

1-8ZHW24 If you create a new Process or Process Interface by selecting File > New > Other, 
the new Process or Process Interface is not created with a default name for 
example, packagename-process where packagename is the name of the package 
where you are creating the new Process or Process Interface.

1-8ZHAW9 TIBCO Business Studio only supports iso-8859-1, also known as Western European 
encodings. 

1-8ZHW0T TIBCO contributions to the Introduction/Welcome pages and the TIBCO samples 
are not localization-ready. 

1-94I5PS Ctrl + S is not enabled to save a file in the Process Editor.

1-8GL8VK After pasting an existing Package with a Service Task into a newly-created Project, 
and then associating the WSDL from the original Project with the new Project 
(either by importing the WSDL or pasting it into the Project, the existing web 
service mappings are recreated. However, neither the Use local WSDL nor the Use 
Remote WSDL options are selected.

Change 
Request ID Summary
 TIBCO Business Studio Community Edition Release Notes
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Version 3.0

Change 
Request ID Summary

1-8ZHAX8 When you have a Service Task that makes an RPC based WSDL call, you cannot 
map a constant to a WSDL parameter by creating a Task script and then mapping 
the script to the WSDL parameter. 

1-8ZJM57 In the Business Object Modeler, if you select an element that refers to an element 
from a referenced Project, the reference is displayed in the Business Object Editor. 
However, if you deselect the element, the reference is still displayed.

1-90A9ZF Adding a new attribute to a WSDL file that is already used by a Service Task breaks 
the existing parameter mappings.

1-8GRC54 There is an incorrect validation error that prevents you from mapping a Decimal 
number to a Java.math.BigInteger.

1-8GL8S7 On Linux, while working with the Process Editor there is sometimes a delay when 
expanding Palette sections or selecting an element and placing it on the process 
diagram.

1-8GL8V3 In areas of TIBCO Business Studio where you can use the mapper, the following 
restrictions existed:

• You cannot drag mappings to the source tree (left side) if the target of any of the 
dragged mappings has multiple inputs.

• You cannot drag multiple mappings to the target tree (right side).

Combining or separating two fields is now done in the Script Editor. 

1-8GL8YO There are cosmetic display issues with the installer dialogs on Linux platforms.

1-8GL903 If you perform a Custom installation and installing both TIBCO Business Studio 
and Asset Central, and then cancel the installation, a Java exception is displayed 
because the installer is attempting to run the Asset Central Configuration Utility.

1-8GL90K If you perform an uninstallation of all products from an installation environment, 
that environment should no longer be selectable in subsequent uninstallations. 
However, with multiple installation environments this is sometimes not the case.

1-8GL91Z If a method used in a Java Service Task is deleted from the Java source, the method 
invocation is grayed out in the Service Task Properties view, however the 
mappings are not completely removed.
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1-8NK27B Non-ASCII characters cannot be used in the Name and Description fields of a 
Process Package Header.

1-8FR0LF ARIS models that include comments fail to import into TIBCO Business Studio.

1-8N1UQX Non-ASCII characters cannot be used in the Author field of a Process Package 
Header.

1-86O7Q8 You cannot create Business Assets (for example, Prince2 Stage folders) from the 
New > Other > Project Management menu because you cannot select a Project. 

Change 
Request ID Summary
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Version 2.1

Change 
Request ID Summary

1-86O76P Occasionally, deleting a Project using the Project Explorer fails. This can be caused 
by external programs maintaining references to TIBCO Business Studio files.

1-75NB0J Migrating a Package to the current version sometimes fails because there are 
attributes in the package file which have namespaces. 

1-75B2Y When uninstalling TIBCO Business Studio, if you have modified any of the files in 
the installation directory (for example, the samples workspace), you are prompted 
as to whether you want to remove the files. Regardless of how you respond to this 
dialog, the files are not removed.

1-86RCSW Copying an Independent Sub-Process Task into a Process in a different Package, or 
copying a Process that contains an Independent Sub-Process Task into a different 
Package, results in a mapping on the Mapping tab that is only partially complete 
and cannot be deleted.

1-86O7FO If an Event-based Gateway starts a Process, it cannot have outgoing Sequence Flow 
to a Timer Event, per the BPMN specification:

If this situation occurs, TIBCO Business Studio displays the following validation 
error in the Problems view:

BPMN 1 : An Event-based gateway starting a process cannot have an 
outgoing transition to a Timer Event.

Placing a Start event before the Gateway should eliminate the error because this is 
permitted in BPMN.

However, TIBCO Business Studio continues to display the error in the Problems 
view despite the Start Event making this a valid BPMN construct.

1-86RAML Mappings between array fields can generate errors in the Script editor that do not 
affect deployment or execution.
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1-86O7PR The import of a WSDL using an invalid URL fails, however no error message is 
displayed.

1-86PV7H Sub-procedure Parameter mapping does not validate that the lengths of source and 
destination data being mapped is the same. For example, currently for integer and 
decimal numbers, if the non-decimal portion of the number is smaller in the 
destination Field or Parameter, no value will be passed at runtime.

1-86PV88 When refactoring a User Task that has a Performer Data Field Participant that is 
shared with other User Tasks that are not being refactored, the User Task in the 
new Independent Sub-Process loses its Data Field Participant. However, in the new 
Independent Sub-Process, a Formal Parameter is created for the Performer Data 
Field. The Independent Sub-Process call task will map the original Performer Data 
Field to the newly-created Formal Parameter.

1-86RCRN If a Web Service operation has a simple-type message part, the corresponding 
Parameter must be mapped even though there is no validation message informing 
you that this is required.

1-86PVAE When creating a Web Services Service Task and selecting an operation that has 
inputs and outputs, the Mapping In and Mapping Out tabs are not immediately 
displayed.

1-86PVBC When using the Concept Modeler, if on the Properties view for an Association, you 
change the Navigability from bi-directional to uni-directional, the Source and 
Destination values do not update accordingly.

1-86PVBT Normally a missing WSDL generates a Problem in the Problems view when 
creating the Task. However if a Service Task that was valid now points to a WSDL 
that does not exist (for example, someone sent you only the XPDL file but not the 
WSDL), an exception is displayed in the error log.

Change 
Request ID Summary

1-71ZF2B It is not possible to delete the last Lane in a Process individually (it can be deleted 
by multiple selection).

1-720AUN Uninstallation of TIBCO Business Studio could be simplified.

1-720AVC It is not possible to switch workspaces from within TIBCO Business Studio.

Change 
Request ID Summary
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1-720AW2 You cannot double-click a Note in a Process to edit it.

1-720AWR When resizing Activities it is possible to make them overlap with other Activities.

1-720AX6 When repositioning an Activity, the tooltip remains at the previous position until 
the Activity is reselected.

1-720AXV When dragging a Sequence Flow, the animation lags behind the line movement.

1-720AYK A new Process should be created when a new Package is created.

1-720AYZ The shortcut key for the final dialog of the installer does not work.

1-720B0H If a Data Field is used as an Actual Parameter to an Activity and then deleted, it is 
not removed from the XPDL file despite not being visible in TIBCO Business 
Studio.

1-720B2K Build script needs to allow creation of an update site.

1-720B4D In the Process Editor, a visual indication of the docking points of an object is 
needed.

1-720B5H The complete set of BPMN features is not present.

1-720B5W The state of the workspace (editors, Project Explorer, and so on) should be saved 
from one session to the next.

1-720B6B Note Association could be improved.

1-720B6Q For a Process with several Activities, if any Activity is on the edge of the 
uppermost lane, the whole Pool moves slightly from its default position and the 
simulation bar chart reading is displayed outside the boundary of the Lane.

1-720B8R Using the shortcut keys in the installer does not work correctly.

1-721Q7X The Custom Installation option refers to the wrong version of Eclipse.

1-721WMF There are performance issues with a Package that contains a large number of 
Processes.

1-721Q9B The extension point com.tibco.xpd.xpdlr2.validator.xpdValidationProvider 
should be renamed.

1-721QBU There are formatting problems with multi-line notes and descriptions.

Change 
Request ID Summary
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1-721QC9 In the Problems view, the Location column should be set.

1-721QF3 Editors from Eclipse Web Standard Tools (WST) are not enabled.

1-721QHH Multiple Participants are not supported.

1-721QHW Improved icons needed for Data Fields and Participants.

1-721QKE Working with Prince2 Assets in the Project Explorer generates and exception.

1-721QKT Loops with Gateways cause infinite loops in Simulation.

1-721QM7 XPDL Join and Split transition restriction elements missing for XOR Gateways.

1-721QNR Simulation Quick Fix does not take effect unless TIBCO Business Studio is 
restarted.

1-721QO6 In the sample workspace, the Project Explorer displays an empty branch in the 
treeview.

1-721QOV Lane resizing not working in certain cases.

1-721QPP Java Virtual Machine error on TIBCO Business Studio shutdown.

1-721QQ5 Exception generated when using bendpoints on a Sequence Flow.

1-721QRE Missing simulation validation message for a Process with parallel Gateway.

1-721QRT Inappropriate validation message for Simulation displayed.

1-75NAZJ Custom installation should not allow user to proceed when no options are selected.

1-75NAZV The Project Explorer displays an empty branch in the treeview if you copy, paste, 
then expand a Package.

1-86O7OC When using Asset Central to commit, the icons, revision numbers, and commit 
dates in the Project Explorer are not all refreshed. They must be selected 
individually and refreshed.

1-75NAXR Links from the online documentation to the TIBCO Support site do not work under 
Windows 2000 and Windows 2003 Server.

1-75NB07 When changing a Gateway from XOR to AND, the Rule Parameter tab should not 
be displayed on the Properties view of the Gateway.

Change 
Request ID Summary
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Known Issues

The tables in this section lists known issues in this release.

• TIBCO Business Studio

TIBCO Business Studio
The table in this section lists issues related to TIBCO Business Studio in this 
release.

Change 
Request ID Summary/Workaround

XPD-799 Summary:  Business Studio fails to launch correctly when installed on 
Windows 7 under the C:\Program Files (x86)\ directory.

Workaround:  Avoid using the Program Files directory for your installation. 

XPD-734 Summary:  When you generate a business service from a message start event it 
will create for you a system participant but this participant has no shared 
resource name on the Advanced tab which results in an error marker.

Workaround: Use the quick fix provided.

XPD-707 Summary:  Cannot import into Business Studio WSDLs with more than one 
binding per service.

Workaround: Avoid having more than one binding for any given published 
service. 

TAP-4386 Summary:  Distributed Application Archive (DAA) files sometimes can have 
long internal paths which can lead to deployment failure.

Workaround: None.

XPD-782 Summary:  A system participant may only be reused for invoking the same 
port type (in the case of virtualized services) or port (concrete services). Also, a 
system participant may not be used to both expose a service and consume 
another (or even the same one). 

Workaround: Be careful to plan how you use system participants.
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XPD-726 Summary:  The following complex type extends complex type construct in a 
WSDL schema is not supported: 

     <s:complexType name="A"> 
        <s:sequence> 
          <s:element name="a" type="s:string"/> 
        </s:sequence> 
      </s:complexType> 
      <s:complexType name="B"> 
        <s:complexContent mixed="false"> 
          <s:extension base="s0:A"> 
            <s:sequence> 
              <s:element name="b" type="s:string"/> 
            </s:sequence> 
          </s:extension> 
        </s:complexContent> 
      </s:complexType> 

Workaround: Change the above construct to use the following type of 
construct instead:

      <s:complexType name="A"> 
        <s:sequence> 
          <s:element name="a" type="s:string"/> 
        </s:sequence> 
      </s:complexType> 
      <s:complexType name="B"> 
        <s:sequence> 
          <s:element name="a" type="s:string"/> 
          <s:element name="b" type="s:string"/> 
        </s:sequence> 
      </s:complexType> 

XPD-766 Summary:  For BOM to XSD conversion, complex type XSD elements or 
attributes with name="value", this setting does not persist correctly. 

For example: 
<xs:complexType name="complexType1"> 
<xs:attribute name="Value" type="xs:string" use="required"/> 
</xs:complexType> 

will result in a BOM attribute with name equal to "value1". This incorrect value 
will be persisted in BOM to XSD export. 

Workaround: Avoid setting XSD complex type attribute and element names to 
"value". 

Change 
Request ID Summary/Workaround
 TIBCO Business Studio Community Edition Release Notes



24 |   Release Notes
XPD-749/

XPD-802

Summary:  The following XSD constructs are not supported in XSD-BOM-XSD 
transformation and are highlighted via validation rules: 
1) Attribute/Element name clash within same complex type 
2) xsd:choice 
3) xsd:abstract 
4) xsd:mixed 
5) XSD any/anySimpleType 
6) AttributeGroup 
7) SubstitutionGroup 
8) Union 
9) xsd:redefine 
10) xsd:notation 
11) xsd:list 
12) xsd:anyAttribute (xsd:any is already excluded) 
13) xsd:key 
14) xsd:keyref 
15) xsd:unique 
16) xsd top-level elements 
17) xsd:complexType as a restriction of another complexType 
18) xsd:extension of a simple type 
19) xsd:group 
20) xsd:all 
21) xsd:top-level attributes 

These special situations are not validated and are documented as restrictions: 

1. If an XML schema contains elements with the same name as a top level 
complex type also in the schema, then after import to a Business Object 
Model the attributes corresponding to these xsd elements will have 
incorrect cardinality. Multiplicity is set to 0..1 regardless of the cardinality 
setting in the original XML Schema. These incorrect cardinality values will 
be persisted in subsequent BOM to XSD exports. 

2. If an imported XML schema contains a Simple Type of base 
xsd:positiveInteger, the equivalent construct in the XML schema generated 
in the BDS project is an xsd:Integer. However, this generated construct is 
missing the constraint "minInclusive=1". 

3. If a class (ClassA) contains attributes and extends (generalizes) another 
separate class (ClassB), then during BOM to XSD transformation, the 
attributes are not persisted in the XML schema if ClassA also has a 
composition relationship to a separate class (ClassC). 

Workaround: The workaround for situation 1 is to rename any elements that 
have the same name as a top level complex type prior to XSD-BOM 
import/transformation. 

Workaround for situation 2: None. 

Workaround for situation 3: On a user defined BOM, instead of using a 
composition relationship to ClassB, ClassA could contain an attribute of TypeB. 

Change 
Request ID Summary/Workaround
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XPD-316 Summary:  When we rename a Business Object Modeler class and also a 
Business Object Modeler package, this should be reflected in the scripts in the 
way that renaming a Business Object Modeler package should rename a 
factory name and renaming a class should rename the factory "create" method 
for that class. 

Workaround: Rename the factory and the class by hand. Content assist should 
help as it will contain the updated value. 

XPD-729 Summary:  The following words are not allowed in the Business Object 
Modeler package name: function, export, import, if, else, switch, case, default, 
while, do, for, break, continue, var, with, catch, finally, void, reserved

Workaround: Rename the Business Object Modeler package to avoid these 
keywords.

XPD-621 Summary:  Reference tasks are not supported.

Workaround: Use copy and paste to copy an existing task. Keep the task you 
want to reference in an xpdl file that will not be deployed, and treat that as the 
master and always copy from there.

XPD-589 Summary:  Eclipse 3.4.2 is not compatible with Xulrunner 1.9 as reported by 
https://bugs.eclipse.org/bugs/show_bug.cgi?id=262929. Xulrunner is 
typically installed as part of the Firefox browser and v1.9 is used by Firefox 
v3.5 and above. The compatible versions of Xulrunner are shown here: 
http://www.eclipse.org/swt/faq.php#browserlinux. 

Workaround: Workaround 1: The preferred workaround is to obtain a 
compatible version of xulrunner. You can configure TIBCO Business Studio to 
use it by adding this to the end of the TIBCOBusinessStudio.ini file:
  -Dorg.eclipse.swt.browser.XULRunnerPath=path_to_xulrunner_1_8 

Workaround 2: If you are not able to use workaround 1, you can also create a 
shell script to start TIBCO Business Studio that will first set GRE_HOME to a 
non existent path (e.g. /dev/nul) and then start TIBCO Business Studio. This 
will use a more basic browser than Firefox and will result in degraded behavior 
wherever the browser control is used including in welcome pages, help content 
and TIBCO Forms preview. 

Change 
Request ID Summary/Workaround
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XPD-230 Summary:  On a business object model child diagram it is not possible to create 
a package element or a view to a package on the main diagram. This is 
expected behavior as we do not want to support packages on child diagrams. 
Consequently, packages do not appear in the child diagram wizard, or as a 
create tool on the palette and context menu of the child diagram. However, it 
appears that it is still possible to Copy/Paste packages onto the child diagram 
canvas and Project Explorer using Edit > Copy, Edit > Paste and Ctrl-C, Ctrl-V. 

Workaround: None. It is discouraged behavior. 

XPD-475 Summary:  The Business Object Modeler does not allow you to enter default 
values as very large numbers or in scientific notation for Fixed Length 
(BigInteger) and Fixed Point (BigDecimal) types. For example, the maximum 
value you can enter at design-time for a default value on a 32 bit Signed Integer 
is 2147483647. If you enter 2147483648 or greater then the designer reverts to 
the last stored default value.

Workaround: None.

XPD-16 Summary: A number of problems exist with content assist for Business Object 
Models in TIBCO Business Studio. These include:

• Braces, {..}, are required in an If statement by the TIBCO Business Studio 
script editor, although they are only optional in JavaScript.

• In the TIBCO Business Studio script editor, valueOf() does not appear in 
Content Assist and is not accepted by script validation, although it is the 
same as toString().

• === operator is not supported by script validation

Workaround: None.

XPD-1 Summary: When there are multiple overview URLs present, which is allowed 
based on the uddi v3 schema, some of them may not be WSDL-type URLs.

Workaround: Only a URL using the "wsdlInterface" value is a WSDL URL that 
can be imported. If a urlType is text, TIBCO Business Studio should not try to 
import WSDL doc from such a URL.

Change 
Request ID Summary/Workaround
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MR 42856 Summary:  When installing TIBCO Business Studio, the following error may 
occur. When it does it indicates that the InstallShield database has become 
corrupted: 

A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be 
available in order to run Eclipse. No Java virtual machine was found after 
searching the following locations I;/StudioA3/tibcojre/14.6.0/bin.

Workaround: If you receive this error, do the following:

1. Try installing TIBCO Business Studio in an empty directory.

2. If you still receive the error, you should delete the _vpddb folder in the 
\Program Files\Common Files\Installshield\Universal\TIBCO\Gen1 
directory.

Warning: If you delete the _vpddb folder, it means that you will not be 
able to use _uninstall to uninstall any TIBCO software. To uninstall 
TIBCO software you must delete the folder where the software is 
installed.

 AMRP-404/

MR 42851

Summary: When using an SMTP Shared Resource template to create an SMTP 
shared resource, there is nowhere to define the From address of the SMTP 
server. This means it is not possible to specify a global From address for the 
SMTP server for all emails sent from that server.

Workaround: Define the address of the SMTP Server for each E-Mail service 
task, individually. To do this:

1. In TIBCO Business Studio, select the E-Mail service task.

2. Click E-Mail in the Properties view.

3. Select Use Custom Configuration.

4. In the box beside Use Custom Configuration, type in the address.

Change 
Request ID Summary/Workaround
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MR 42797 Summary:  If you installed TIBCO Business Studio using the Solution 
Designer persona, you must reset the target platform before exporting or 
deploying projects to the TIBCO Silver BPM destination, otherwise you will 
receive the following error.

To reset the target platform, do the following:

1. In TIBCO Business Studio, select Windows > Preferences. The Preferences 
dialog is displayed.

2. Select Plug-in Development > Target Platform. The contents of the 
Location field are as follows:

STUDIO_HOME/eclipse_platform/ganymede/eclipse/../../../components/s
hared/1.0.0

where STUDIO_HOME is the directory where you installed TIBCO 
Business Studio.

3. From the Location field, use the drop-down list to change the contents of 
the Location field to:

STUDIO_HOME/eclipse_platform/ganymede/eclipse/

where STUDIO_HOME is the directory where you installed TIBCO 
Business Studio.

4. Click Apply, then OK.

MR 42796 Summary: When installing TIBCO Business Studio, you cannot use your own 
Eclipse installation as documented in the Installation Guide. This is due to an 
error in the installer.

Workaround: None.

Change 
Request ID Summary/Workaround
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MR 42787 Summary: When using a Web Service Service Task, you cannot map 
JavaScript to a WSDL that contains a single primitive element.

Workaround: None.

MR 42605/MR 
42376

Summary: A project for deployment in TIBCO ActiveMatrix BPM should not 
reference processes, Business Object Models or XPDL files from another 
project. This is because the version numbers of the processes, Business Object 
Models and XPDL files will be different from the project referencing them and 
TIBCO ActiveMatrix Workspace requires that the version numbers match.

Workaround: None.

MR 42523 Summary:  When trying to launch the TIBCO ActiveMatrix Administrator 
from TIBCO Business Studio, a Session Timeout error is displayed. 

Workaround: Select Window > Preferences, and type Web Browser in the 
filter field. Set the browser either to be external or to be Firefox. 

MR 41603 Summary: In versions before TIBCO Business Studio Version 3.3.0, WSDLs 
that were imported using the Imported using URL option were stored as the 
original URL that the WSDL was imported from. This meant that however you 
configured the Endpoint Resolution in the Service Task, the Service Task would 
use the original URL of the WSDL. This causes problems when deploying an 
application to TIBCO Silver BPM.

Workaround: When the project is imported into TIBCO Business Studio, a 
validation error reports that the WSDL location is incorrect. If you right-click 
on the validation error and select Quick Fix, the WSDL location is corrected.

MR 39053 Summary: If TIBCO Business Studio has crashed or existed abnormally, and 
then been restarted, sometimes an error is displayed. This is due to a 
connection to an internal database that uses being lost. Click OK on the error 
dialogs repeatedly until the error dialog closes and you are returned to TIBCO 
Business Studio.

Workaround: None.

MR 37947 Summary: Transforming XPDL processes into SVG graphical format is still 
experimental in this release of TIBCO Business Studio. Currently, associations 
and artefacts are not transformed.

Workaround: Select JPEG Export Format.

Change 
Request ID Summary/Workaround
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1-9YTWOD Summary: When running a simulation, the simulation perspective is not 
always properly reset. This sometimes results in symptoms such as the 
simulation controls being disabled, the simulation progress data on the Process 
Editor being either absent or incomplete, and the simulation results window 
being blank.

Workaround: Select Window > Reset Perspective.

1-9YIL89 Summary: This relates to the Data Source Explorer: Work done in offline 
mode seems to be lost on restarting TIBCO Business Studio.

If the connection is in a disconnected state, when you select the Browse for 
stored procedure button on a Service Task, TIBCO Business Studio tries to 
connect to the database; it does not attempt to use any schema that may have 
been saved offline. If the network or remote server is not available this attempt 
to connect will fail.

Workaround: Use the Save Offline option whilst connected to the network. If 
you need to restart work when you are disconnected from the network, select 
Work Offline on the Data Source Explorer before clicking the Browse option on 
the Service Task.

1-9XY23T Summary:  When long running background activities are taking place (for 
example, when the 'Building the Workspace' message is displayed) then in 
some cases process selection dialogs will present incorrect results. 

Workaround: If you see a dialog not display the items you expect, wait for the 
build to complete and try again.

1-9XXGB9 Summary: In TIBCO Business Studio version 3.2, a WSDL file that has been 
generated from XPDL (for example, from a start message event) is marked as 
Derived. This did not apply in previous versions, and WSDL files migrated 
from previous versions of TIBCO Business Studio are not automatically 
marked as Derived. A derived file is always overwritten when there are 
changes to the XPDL file from which it is derived. 

Workaround: If you want to keep a migrated WSDL file synchronized with 
the XPDL, you should manually set the Derived flag when migrating to release 
3.2. You can do this by selecting Properties from the context menu of the WSDL 
file and selecting the Derived checkbox.

1-9WP7VH Summary: When WSDL is generated from XPDL files, if the WSDL editor is 
open, changes to the WSDL file are not reflected.

Workaround: Reopen the WSDL editor.

Change 
Request ID Summary/Workaround
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 1-9EUIY1 Summary: You cannot use the command line to generate process package 
documentation if there are any workspaces open. The expected behavior is that 
you cannot generate process package documentation if the workspace that 
contains the package is open.

Workaround: Close all workspaces before generating process package 
documentation from the command line.

1-9EUIYV Summary: If you have installed TIBCO® French Language Pack (Eclipse 
Platform) before installing TIBCO Business Studio, the language pack is not 
detected.

Workaround: You must link the language pack plug-ins with the TIBCO 
Business Studio installation as described in TIBCO Business Studio Installation 
(post-installation tasks).

1-9DABLW Summary: In the Import Wizard Information dialog there is a XSLT selection 
browser that allows you to select an XSLT file. This dialog does not list any .xslt 
files on Linux.

Workaround: Either manually enter the path to the XSLT file or rename the 
file extension to .xsl.

Change 
Request ID Summary/Workaround
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1-9DCCY6 Summary: When working with multiple TIBCO Business Studio 
implementations, the SVN Team > Replace With > Latest from Repository 
command behaves differently depending on whether any local changes have 
been made.

For example, suppose one TIBCO Business Studio user saves a package to the 
repository, creating revision 57. Another user checks out revision 57. In the 
mean time, the user who created revision 57 makes more changes and creates 
revision 58. The user who checked out revision 57 has a working copy that is 
now out of synch with the repository. If they enter the Team > Replace With > 
Latest from Repository command, the following will happen:

• If the user whose working copy is out of synch has made local changes, a 
pop-up dialog is displayed warning that local changes will be lost. If the 
user clicks OK, the latest revision from the repository replaces the current 
working copy and the user is in synch with the repository.

• If the user whose working copy is out of synch has not made local changes, 
no dialog is displayed, but the working copy is not overwritten with the 
latest revision from the repository.

Workaround: If you are sure that you have not made any local changes, use 
the Team > Update option. If you use this method there is no warning about 
overwriting your working copy, so be sure that you have not made any local 
changes that you want to preserve.

1-8ZPEGX Summary: When a Package file is copied and pasted, duplicate IDs are 
created and a problem is displayed in the Problems view. This problem 
prevents deployment until a quick fix is applied to the correct the problem.

However, if the original Process was deployed before the Package file was 
copied and pasted, the Packages with duplicate ID errors have their Modules 
listed as deployable modules in the Select Modules dialog of the Deployment 
wizard even though the quick fix has not yet been applied to the correct the 
duplicate ID problem.

Workaround:  Perform a clean on the Project by selecting the Project > Clean 
menu option.

1-8ZJMK3 Summary: TIBCO Business Studio cannot validate the data type of literals in 
user defined scripts. This means that if you specify an invalid data type you are 
not warned.

Workaround: Make sure you use the correct data type for literals.

Change 
Request ID Summary/Workaround
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1-8ZJM43 Summary:  Sometimes, content assist does not display the up to date contents 
in the XPATH Script Editor. 

Workaround: If you change the focus to another view, then return to the 
mapper, the correct contents will be displayed. In some cases, you may need to 
restart TIBCO Business Studio.

1-8ZJM4S Summary:  There are some tasks for example, Receive, Send task and 
Intermediate Message events where TIBCO Business Studio does not flag data 
type mismatch errors for mappings.

Workaround: None.

1-8ZJMKX Summary: When TIBCO Business Studio is installed for the Business Analyst 
persona, the implementation details section for the Service Task is visible but 
you cannot enter any implementation details for the Service Task.

Workaround: None.

1-8ZHBB8 Summary: When creating a new process from a diagram fragment, the 
Destination Environment is not reflected in the new process.

Workaround: You have to re-specify the Destination Environment in the new 
process.

1-8ZHBEV Summary: The following error is displayed if you create a process in an older 
version of TIBCO Business Studio and then close the older version of TIBCO 
Business Studio while the Editor is still open. If you then try and open TIBCO 
Business Studio Version 3.0 using the workspace from the older version of 
TIBCO Business Studio, you get the following error.

Error opening the editor. 
Reason:
The process for this editor no long exists: New process open but not saved on 
last exit?

Workaround: Close the Editor before exiting the older version of TIBCO 
Business Studio.

1-8ZJM7G Summary: When you migrate a Concept Model from an earlier version of 
TIBCO Business Studio to this version of TIBCO Business Studio, the domain 
values alias are not migrated, although the domain values are.

Workaround: You must redefine the domain values alias for the Concept 
Model.
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1-8ZHB35 Summary: A Business Object Model file cannot be reopened if its applied 
UML profile has been deleted, moved or modified.

Workaround: None.

1-8ZJMAD Summary:  If you have installed Asset Central, when uninstalling TIBCO 
Business Studio 3.0, uninstall sometimes hangs when uninstalling Asset 
Central. 

Workaround: If uninstall has reached the TIBCO Business Studio Asset 
Central dialog and appears to have hung, close the dialog. Uninstall then 
completes. You must then manually remove the Asset Central service. To do 
this:

1. Open a command prompt.

2. Navigate to the directory that contains your Asset Central binary files. For 
example installation_environment\studio\3.0\assetcentral\bin where 
installation_environment is the location where you installed TIBCO Business 
Studio Version 3.0.

3. Run the following command:

Apache.exe -k uninstall -n "AssetCentralService"

where AssetCentralService is the name of your TIBCO Business Studio Asset 
Central Service.

The TIBCO Business Studio Asset Central Service should be successfully 
removed.

1-8ZHB6Y Summary: If you use Import to import a simulation historical case, and the 
XLS has the Autofilter option set, the import fails. See 
http://saloon.javaranch.com/cgi-bin/ubb/ultimatebb.cgi?ubb=get_topic&f=
1&t=020238 for more information.

Workaround: Deselect the Autofilter option.

1-8ZHAXX Summary: If you update your process interfaces while your WSDL editor is 
open, the parameters for the web service operations are displayed as 
Undefined type in your WSDL file.

Workaround: Close and reopen your WSDL editor to see the updates.
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1-8ZJMAS Summary: On Linux, if you select About TIBCO Business Studio > Plug-in 
Details, you will get an error similiar to the one below:

The signature cannot be verified for this signer META-INF/ECLIPSE.RSA in 
this bundle: 
/home/linuxuser/ravi/studio/3.0/eclipse/plugins/org.eclipse.platform_3.3.
3.r33x_r20080129

Workaround: You may safely ignore this error.

1-8ZHB7F Summary: If you are installing TIBCO Business Studio on Linux, you may 
receive the following warnings: 

libxcb: WARNING! Program tries to unlock a connection without 
having acquired a lock first, which indicates a programming 
error. There will be no further warnings about this issue.

libxcb: WARNING! Program tries to lock an already locked 
connection, which indicates a programming error. There will be no 
further warnings about this issue.

Workaround: You can safely ignore these warnings.

1-8ZHB8T Summary: CTRL + Z (Undo) does not work from the Process Interface 
Properties View, if the Properties View is the only view that has focus.

Workaround: Make sure that the Project Explorer or Editor also has focus 
before changing a property on the Process Interface Properties View.

1-720AU7 Summary: TIBCO Business Studio allows you to move a Lane between Pools 
even when there are Sequence Flows from objects contained within the Lane. 
This results in Sequence Flows crossing Pool boundaries which is not allowed 
in BPMN. TIBCO Business Studio should prevent the move in the same way 
that it prevents individual objects with outgoing sequence flow from being 
moved between Pools.

Workaround: None.

1-720B16 Summary: Online context help is not available for Properties views.

Workaround: Perform a search for the required topic.

1-721WJ3 Summary:   In the TIBCO Business Studio user interface, there are menu items, 
wizards and so on that should be removed from the product, but cannot be due 
to technical issues with Eclipse.

Workaround:   None.
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1-721QB4 Summary: The Problems view has a filter which may be set to the selected 
element or selected element and its children. The selected element must be a 
file; if a sub-file artifact is highlighted in the Project Explorer, a misleading set 
of defects may be displayed and the list will only be refreshed when a file-level 
artifact is selected. For example, if a Process is selected in the Project Explorer, 
and then a change made that would trigger a Problem whilst the above filters 
are selected, the Problem will only be displayed when the XPDL file that 
contains the Process is selected in the Project Explorer.

Workaround: None.

1-721QDT Summary: It is possible to edit the weighting of a simulation parameter while 
the simulation is running, however this has no effect on the currently running 
simulation. Any changes made are applied to the next simulation run.

Workaround: None.

1-721QE8 Summary: In the Properties view for a Process, on the Simulation tab, 
Sequence Flows from a Gateway that have been deleted are still displayed and 
assigned a Weighting for simulation purposes.

Workaround: Click the Remove button to delete the extraneous Sequence 
Flow.

1-721QIQ Summary: Settings made from the Windows Print dialog (for example, 
Landscape or Portrait) take effect for the current print job, but are not 
preserved after exiting the Print dialog. This occurs whether you access the 
Print dialog by selecting File > Print or by selecting File > Diagram Print 
Setup and clicking the Properties button.

Workaround: None. This is a known Eclipse problem.

Change 
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1-721QJZ Summary: Any Process object that causes the simulation flow to branch and 
not re-join can potentially cause invalid simulations caused by multiple End 
Events. The simulation stops at the first End Event that it encounters, resulting 
in an incomplete (invalid) simulation. Examples of Project objects that can 
cause this are:

• Conditions that are not fired. For example:

• Sequence flows that branch and do not join re-join the main flow. For 
example:

Workaround: None. Avoid creating this situation in your Process.

1-721QND Summary: In the Process Editor, when the view of a single-Lane Process is 
zoomed out and an object is added to the surrounding empty space, it should 
accommodate the object within the Lane. However, the boundary of the Lane 
disappears until you select another object on the Process.

Workaround: None.

1-721WSR Summary: Pausing then re-starting a running simulation sometimes 
generates an exception in the log.

Workaround: None. The simulation runs normally apart from the exception.

Change 
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1-721WTR Summary: Under certain circumstances, simulations can generate an 
OutOfMemoryException. A large number of queued cases in the current 
simulation can cause this problem. The factors that influence the number of 
queued cases are:

• the frequency and number of case starts

• Activity duration

• the number of Activities

Workaround: Avoid creating a situation where there is a large number of 
queued cases.

1-721WUH Summary: As part of the pre-processing for simulation, the Process is 
changed even though it is invalid. Ideally all changes made by the 
pre-processor should be reported as problems in the Problems view and 
corrected by the user.

Workaround: None.

1-721WWK Summary: On Windows 2000, if there is no printer attached to the machine, a 
null pointer exception is generated when selecting File > Diagram Print Setup.

Workaround: Make sure a printer is connected before accessing the Print 
Setup dialog.

1-75NQZ7 Summary: There may be duplicate bookmarks in the PDF output of a 
simulation comparison report.

Workaround: None; this is due to the way the 3rd party reporting tool 
generates bookmarks.

1-7NB2L Summary: Under certain circumstances during Simulation, the Simulation 
time display stops displaying some of the time information (such as the 
minutes or seconds).

Workaround: None.

1-86O77Q Summary: Processes that you intend to simulate must contain only 
alphanumeric characters or spaces in their names.

Workaround: None.
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1-86O7CU Summary: On Windows 2003, if you select part of a Process, select Copy as 
Image, then paste the image into another application, the colors of the pasted 
image do not display properly. Additionally, in TIBCO Business Studio some of 
the buttons, wizards, and so on display with a black background.

Workaround: None.

1-86O7DB Summary: In the Project Explorer, under Deployment Servers, if you 
undeploy the Processes from the Package that contains them, the Package 
becomes empty. However, you cannot delete the empty Package.

Workaround: None.

1-86RCSH Summary: If you run a simulation successfully then attempt to use the Run 
configuration window (select the Run > Run... menu option) to redefine the 
existing launch configuration to call another Package that contains a Process 
with the same name, the dialog accepts your configuration changes as valid. 
However, internally the id of the old Process is retained which causes the 
simulation to fail to run (an error message is displayed that the Process does 
not exist in the Package). 

Workaround: Launch simulation from context menu in the Project Explorer. 
Alternately you can force the configuration dialog to update by browsing to a 
differently named Process (this will force the launch configuration to be 
updated). Then browse again to the Process that has the same name as the 
original but is located in a different Package.

1-8GJ19N Summary: When the mapper is first displayed for an Activity, any items that 
are already mapped should be automatically expanded so that the item is 
visible. Items that are not mapped should remain collapsed.

Workaround: None.

1-86SUPT Summary: The tooltip text for the button to change between the Process 
Analyst and Process Developer capabilities is not displayed after initially 
clicking the button.

Workaround: None.

1-86RCS2 Summary: An event-based XOR Gateway generates an attribute for 
simulation even though it should not be capable of being simulated.

Workaround: Assign a name to the element.

Change 
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1-86O7IB Summary: Within the Business Intelligence Reporting Tool (BIRT), when 
laying out a report, there is a tool that allows you to insert an image that is 
located elsewhere by specifying a URL. Using this method generates the error 
message:

Image (id = 66): 
+ There are errors evaluating script 
"http://mysite.com/images/companylogo.jpg". 

Workaround: Embed the image in the report.

1-86O7IS Summary: Within the BIRT, if you copy a Data Set, the Alias and Display 
Names from the original Data Set are not copied.

Workaround: Manually recreate the Aliases and Display Names on the 
copied Data Set.

1-86O7JT Summary: Validation of JavaScript entered in TIBCO Business Studio occurs 
in two phases:

• The script is validated for correct syntax.

• If syntactically correct, the script is validated against the selected 
Destination Environment.

This leads to the situation where you enter script that is not valid for a 
Destination Environment, but you are not informed of this until you have 
finished entering the script and it passes the first phase of validation (syntax 
checking).

Workaround: None.

1-86RAKP Summary: The Edit > Undo and Edit > Redo menu options for scripts do not 
work as expected.

Workaround: Press Ctrl + Z and Ctrl + Y to undo and redo respectively.

1-86O7LI Summary: The buttons OK and Cancel are not necessary on the Properties 
dialog for products because the information on this dialog cannot be changed. 
To view the properties, select Help > Software Updates > Manage 
Configuration, right-click a product from the left hand pane, and select 
Properties.

Workaround: None.

Change 
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1-86O7NV Summary: When entering JavaScript it is not supported to pass a Boolean 
Data Field to a function that expects a Boolean expression.

Workaround: None.

1-8GJ1A3 Summary: In areas where you can enter JavaScript, content assist should not 
appear after single line comment or within multi-line comments, however it 
does appear.

Workaround: None.

1-86RAL6 Summary: Subversion generates an error if in the SVN Repository Exploring 
perspective, you right-click a project in your local repository, select Import, and 
then attempt to import a project that is in your workspace, but not under 
Subversion control.

Workaround: Source control your Projects using the Team context menu in 
the Project Explorer. For more information, see the TIBCO Business Studio 
Modeling User's Guide.

1-86RALN Summary: In the History view for SVN, you can right-click an item and select 
Set Commit Properties. The resulting dialog allows you to retroactively enter 
comments for the selected revision. To exit the dialog you must specify an 
Author, however if you have not set up the SVN repository to use 
authentication, the Author that you specify is not then listed in the Author 
column in the History view. Note, however that retroactively entering 
comments for revisions is not recommended practice.

Workaround: None.

1-86O7MG Summary: In the SVN Repository Exploring perspective, in the SVN 
Repository view, right-clicking and selecting Properties displays properties at 
the highest (repository) level, but not at lower levels (for example, the Project 
level).

Workaround: None.

1-86O7MX Summary: After selecting Team > Commit and saving changes to SVN, you 
must press F5 to see those changes reflected in the History tab.

Workaround: None.
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1-86RANT Summary: In a Process with Simulation set as the Destination Environment, 
when you right-click the Process and select Prepare Simulation, the necessary 
Parameters are created for simulation. Despite deleting the values for the 
created Parameters and deleting the Parameters from the Project Explorer, they 
are still displayed in the Properties view for the Process.

Workaround: None.

1-86O7QP Summary: Reserved words for JavaScript (for example, "return") when used 
in a WSDL cannot be mapped in a Service Task.

Workaround: Avoid using words that have special meaning in programming 
languages as variables.

1-86O7R6 Summary: In the Concept Modeler, copying and pasting on the editor does 
not work correctly. 

Workaround: Copy and paste Concept Model objects using the Project 
Explorer.

1-86PV6J Summary: TIBCO Silver BPM allows the mapping of repeating elements to 
Arrays. A WSDL that does this cannot be mapped in the same way in TIBCO 
Business Studio. In TIBCO Business Studio, you cannot map simple types to 
simple types that are within an array of complex types.

Workaround: None.

1-86PVAV Summary: When moving a Group between Lanes it often moves to the top of 
the uppermost Lane, regardless of where you position it. Also, when deleting a 
Group, the Process Editor does not refresh correctly and the Process Editor 
must be closed and then opened to reflect the change to the Process.

Workaround: None.

1-8GL8RP Summary: On Linux, when connecting remotely and using the Process Editor, 
black areas are sporadically added to the diagram when adding new elements, 
using context menus, moving objects, and so on.

Workaround: None.

1-8GL8SP Summary: On Linux, printing is not enabled in TIBCO Business Studio 
because it is not supported by the version of Eclipse bundled with TIBCO 
Business Studio.

Workaround: None.

Change 
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1-8GL8TO Summary: In SUSE 10, objects in the Process Editor and Concept Modeler 
have dark backgrounds for images (for example, on Activities and Concepts).

Workaround: None.

1-8GL8U5 Summary: On Linux, when using Wizards (for example to rename a Process), 
pressing Enter rather than clicking the Finish button does not work correctly. 

Workaround: Click the Finish button, or press Tab before pressing Enter.

1-8GL9UM Summary: In the Concept Modeler, when using the Zoom options, the 
graphic display of the Palette sometimes becomes slightly degraded.

Workaround: None.

1-8GL8WB Summary: There can be a noticeable performance degradation when 
manipulating large amounts of data (for example, running simulation or 
deleting multiple Activities from a Process with more than 200 Activities).

Workaround: If the you suspect that the performance degradation is due to 
the validation of the Project, turn off in-memory validation by de-selecting 
Project > Build Automatically. When you want to package your project, select 
either Project > Build All or Project > Build Project.

1-8GL8WS Summary: The TIBCO Business Studio Welcome Page cause problems on 
some Linux 64-bit installations. 

Workaround: Use workspace created on the different machine (in order to 
skip the Welcome page on startup).

1-8GL8X9 Summary: When undoing the deletion of a Concept in the Concept Modeler, 
the position and appearance of the Concept is not restored.

Workaround: None.

1-8GL8XQ Summary: The Asset Central Configuration dialog will not be displayed if 
your PATH environment variable is not configured to point to a version 1.5 or 
later JRE. 

Workaround: For information about how to configure your PATH 
environment variable, see TIBCO Business Studio Installation Guide.
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1-8GL8Y7 Summary: Copying a special folder (for example, a Services folder) and 
pasting it into another BPMN project does not retain the special folder setting 
of the copied folder. You must redesignate the folder as a special folder after 
the copy.

Workaround: None.

1-8GL8ZM Summary: If TIBCO Business Studio is left idle for more than approximately 
30 minutes, process mappings can disappear.

Workaround: To restore the mappings, restart TIBCO Business Studio.

1-8GL92G Summary: When a Java Service Task in TIBCO Business Studio maps a 
response value using a specific array index value, and that index does not exist 
at runtime, an error occurs. For example, mapping RV[4] when only elements 0 
to 3 exist causes an error.

Workaround: None.

1-8GL91I Summary: When a project is shared with SVN, if you close TIBCO Business 
Studio with a file that has unsaved changes, you are prompted to save the 
changes. Upon restarting TIBCO Business Studio, the SVN project is marked to 
indicate that a commit is pending, however the Console view for project 
sharing is blank. 

Workaround: Set the Console view back to SVN Console.

1-8GRL9E Summary: In the SWDIR\eaijava\pojo.properties configuration file, foreign 
characters not in the default character set can be expressed using UNICODE 
escape sequences. For example, the following equates to a EURO symbol (£):

OUTPUT.TEXT = \u20ac

Workaround: None.

1-8GRLA5 Summary: The deployment extension point interface has changed since 
Version 2.0. The interface com.tibco.xpd.deploy.model.extension.Connection 
has a new method, validateModule() that needs to be implemented in TIBCO 
Business Studio Version 2.1. Deployment extensions developed against TIBCO 
Business Studio Version 2.0 must be recompiled against TIBCO Business Studio 
Version 2.1. The new method has to be implemented, but it can return true to 
retain the existing behavior.

Workaround: None.
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